1

I have inherited a complex website which has the Features and Views module installed. I can configure a Feature to include a View as you would expect.

However, I'm putting together a private website which also has Views and Features installed. My problem is Views does not appear as an option to select data from when configuring the Feature.

Is there a setting or module which is responsibly for exposing Views in Feature create/edit mode ????

The image on the Feature project page seems to suggest Views should be there by default.

Any help, please !

0

Perhaps all the available views have been added to other features? Try enabling the checkbox "Allow conflicts to be added" in the 'Advanced Options' section of the 'Create' page. If you can see the views then, it means they are already assigned to other features.

  • Thanks for commenting but the site is entirely fresh and there are no pre-existing features with any packaged views – sisko May 15 '16 at 16:12
  • Are there views available to be added? Perhaps all the available views are disabled? Have you created a new view and checked to see whether it is available? – Frank H. May 15 '16 at 16:20
  • Yes, there are 4 views. I've even been enabling some of the default views but Features still won't show a Views interface – sisko May 15 '16 at 16:42
  • 1
    Hey Frank, you were right. I just realized I wasn't patient enough to see the Views interface when I checked the "allow conflicts" box. Views now displays but there is literally no conflict with any other feature – sisko May 15 '16 at 17:04
  • 1
    You have been right all along. I appreciate all your help. Thank you – sisko May 18 '16 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.