1

I have enabled Exposed Group Filters in views. When I set the option to "input required" no results are shown, also does not give me an option to input any filter from the selected option. All I get is an Apply button.

My Query is:

How do I let the users see all results in the view first, let the user input their filter criteria from the allowed list & then show them the results basis of the filters?

I have tried Better Exposed Filters, its still not giving me an option to input my query.

Please advice.

Thanks

0

The exposed filters are not displaying because the view is empty and therefore not rendering. As per this issue, if you give your view something to display when it is empty (i.e. a no results behaviour setting), it will show your filters.

Then, if you really don't want to show 'no results' (which is what most people put in there) you could hide it wish CSS.

  • Hi Darvanen, Thank you for the input. My view does have content to display. If I disable the filter, I can see all results. however, if the filter is set up, the view comes up empty. I want to show all the results in the view to the user, which they then can filter out basis of the exposed filters. How do I achieve that? – Girish Cholayill Nov 14 '16 at 18:04
  • By having your filters set to 'input required' you're blocking all content until they are filled out. Please try putting something in the no results behaviour, just a bit of global text, you'll see what I mean. If you want to show all results, then you need to turn off 'input required', or provide default values for the filters. – Darvanen Nov 14 '16 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.