When I am logged as an administrator and try to access Content from the administrator menu, the corresponding window pops up, with the add content link, but just below, I get the following error message:

The requested page "/mywebsite/?q=admin%2Fcontent%2Fnode&render=overlay" could not be found.

although content already exists. What is causing this and how can I get rid of it? I am on Drupal 7 release 12. Thanks.


If anyone has ideas, tips, suggestions about what is causing (or could cause) this issue, it is welcome. Could I have modified the config by accident (if yes, which)? Is there a tool (other than FireBug) to debug this issue? I plan to re-install a system from scratch and check whether the error happens too. Thanks.

Update II

Here is what I get when requesting Content from the Administrator menu:

enter image description here

When I click on Amdinistration, I get the following:

enter image description here

First, I notice something strange: an empty entry in the provided list. Why? I don't know.

Second, when I click on Content from this page, I am not facing the issue I reported above. I noticed a difference in the URLs between both methods:

http://www.mysite.com/#overlay=%3Fq%3Dadmin%252Fcontent%252Fnode <- NOT OK
http://www.mysite.com/#overlay=%3Fq%3Dadmin%252Fcontent <- OK

2 Answers 2


The url you have posted translates to


This is how the overlay works, which displays a regular page, but adds a param to tell drupal it should be rendered as the overlay (no header, footer etc is rendered).

The problem could be that overlay is disabled, or that the url isn't encoded as it should.

If you use clean urls, you shouldn't see the ?q=...

  • I have actually disactivated the overlay, but the issue remains. I have also re-activated it, but the issue remains too. Commented Feb 13, 2012 at 14:54
  • @JVerstry have you cleared cache when doing so?
    – googletorp
    Commented Feb 13, 2012 at 14:57
  • I don't recall requesting or configuring '?q=' on my urls. I believe a module has set this itself. Is there a way to disable this? REM: a direct request to mysite.com/admin/content/node (with or without ?render=overlay) gives a 404... Commented Feb 13, 2012 at 15:03
  • I tried the disactivation/activation cycle again, with clearing cache, but it did not solve the issue. However, I have found an issue with the URL. I'll explain in the question. Commented Feb 13, 2012 at 15:17
  • I found about Clean URLs and ran the test, but it fails. Commented Feb 13, 2012 at 15:51

After performing some tests on a new installation, all seems to indicate that my site was installed in a corrupted directory. I had used an installation script delivered by my Internet host, but the install directory was most probably not cleared properly. So my bad on this one.


After all, this is a bug I can replicate from a clean system. I opened an issue.

The bug disappears when disabling Administration views and clearing cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.