0

The views_data:fr BLOB data IN THE cache_default TABLE is too large, and I get this error when I try to import the table on a shared server (OVH).

ERROR 1118 (42000) at line 3302: The size of BLOB/TEXT data inserted in one transaction is greater than 10% of redo log size. Increase the redo log size using innodb_log_file_size.

INSERT INTO `cache_default` (`cid`, `data`, `expire`, `created`, `serialized`, `tags`, `checksum`) VALUES
('views_data:fr', 0x613a3135303a7b733a383a227761746368646f67223b613a31323a7b733a353a227461626c65223b613a343a7b733a353a2267726f7570223b4f3a34383a2244727570616c5c436f72655c537472696e675472616e736c6174696f6e5c5472616e736c617461626c654d61726b7570223a333a7b733a393a22002a00737472696e67223b733a383a225761746368646f67223b733a31323a22002a00617267756d656e7473223b613a303a7b7d733a31303a22002a006f7074696f6e73223b613a303a7b7d7d733a393a2277697a6172645f6964223b733a383a227761746368646f67223b733a343a2262617365223b613a333a7b733a353a226669656c64223b733a333a22776964223b733a353a227469746c65223b4f3a34383a2244727570616c5c436f72655c537472696e675472616e736c6174696f6e5c5472616e736c617461626c654d61726b7570223a333a7b733a393a22002a00737472696e67223b733a31313a224c6f6720656e7472696573223b733a31323a22002a00617267756d656e7473223b613a303a7b7d733a31303a22002a006f7074696f6e73223b613a303a7b7d7d733a343a2268656c70223b4f3a[...]

I know that increasing the value of innodb_log_file_size solves problem, but it's impossible in a shared server.

Is it possible to reduce this table?

I tried disabling the view caching in the advanced settings, disabling the cache for that single view, but it has no effect.

I feel that the more views we have, the more space the views_data:fr column takes.

  • If the hosting is so limited now, you’re almost certainly going to get more problems as the site gets bigger and more complicated. You might solve this particular one, but something else will be the problem. Just be honest with the client, tell them the software the site is built on simply requires better hardware – Clive Feb 7 '18 at 16:55
0

You might try compressing the data before sending it. There's a module for that: compressed_cache

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.