0

can any one help me how to expose the taxonomy term filter in view in drupal 7. I have created a view with

   Fields:

     1. Title

     2. Body

    FILTER CRITERIA:

     Has taxonomy terms (with depth)

when i expose this filter it is not getting exposed.

can anyone help me how to expose the taxonomy term field.I need to see the content get filtered based on the taxonomy term.

1

When you select the filter 'Has taxonomy terms (with depth)' under your 'Filter Criteria' section, make sure you select the correct vocabulary on the first screen of your setup. There is a section for you to determine which vocabulary's terms you are trying to select from.

On the second screen, make sure you check the 'Expose this filter to visitors, to allow them to change it' checkbox. It is actually unchecked by default.

It should then show up at the top of your view in the preview window.

0

Try exposing the Tag field you have in your node, so if the tags you want to sort on are in a field called 'Taggies' you would expose that field

1
  • Even this one also not working
    – bharathi
    Mar 19 '12 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.