anyone know how to create a URL alias and not redirect the user? I have a node with its alias set to /sign-up, but I also want it accessible via /caregiver/sign-up. I created a URL alias, but it seems to just do a redirect to /sign-up.

I checked the current redirects list and the only redirect for sign-up I am seeing as for an old page that redirects from /activate to /sign-up


1 Answer 1

  • Get the node id that have /sign-up as alias (lets say it's node/42)
  • Go to /admin/config/search/path/add
  • Fill the form as mentioned in the description : Existing system path : /node/42 Path alias : /caregiver/sign-up
  • Save the form
  • you can now access the node with /caregiver/sign-up alias :)
  • 1
    I had already created the URL alias as your answer is saying. I resolved this by unchecking Enforce clean and canonical URLs. in the url redirect setting sand then load an incognito window and it started working as it should. Only downside is I can view the page at say, node/12, and it doesn't redirect to the clean url. I think that is ok, I will just add a node/* deny to my robots.txt file
    – Ronnie
    Commented Nov 21, 2018 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.