1

I am dealing with an older d8 site that has a feed item of a custom type with custom processor. When I go to admin/content/feed and click on an existing one and I go to feed/id/import I get access denied. If I add a new one I do not get the same error but I am trying to understand what defined support for the "import" operation for a feed? enter image description here

enter image description here

2

Feeds locks a feed when you start an import from it. As soon as the import finishes, the feed gets unlocked again.

When a feed is in a locked state, you cannot initiate another import. Therefore feed/id/import results into an access denied page.

There can be occasions in which an import failed to finish. This can for example be caused by bugs in Feeds or other modules. An other possible cause is that the database server restarted or stopped in the middle of an import. If you use periodic import on the feed, it may be that the import did not fail to finish, but just needs a few more cron runs.

To unlock a feed, go to the feed page and click on the "Unlock" button or go to feed/id/unlock. If you see no button or get access denied for that path as well, try to clear caches. Drupal caches access to menu paths (Feeds does clear the cache for the paths in question when a feed gets locked or unlocked).

  • Thanks a lot. I was not sure why the issue resolved itself and was scratching my head. I think one feed was locked and stuck in locked. Doing some cache rebuild and cron runs most likely fixed it for me. – awm Dec 6 '18 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.