0

I'm trying to use the RPX module and I get as far as step 5.

I've installed and enabled the plug enter image description here

checked permissions enter image description here

and selected "visitors"

enter image description here

Then i get here.

Visit admin/config/people/rpx and enter your Janrain Engage API key.* This API key must be entered for the module to function properly.

I find that the path admin/config/people/rpx doesn't exist.

I'm running Drupal 7.12 with RPX 7.x-2.2

Is this a common problem, does anyone know how to fix it?

  • Just open the rpx.module file and search for hook_menu and find link ! – niksmac Apr 21 '12 at 3:48
  • @NikhilMohan is that suppose to give me a correct link or something ? – mcgrailm Apr 21 '12 at 4:03
  • Yes, this hook is used for defining urls, that they supposed to use. api.drupal.org/api/drupal/modules%21system%21system.api.php/… – niksmac Apr 21 '12 at 4:06
  • open 'rpx_ui.module' in line 17 you can see that url defined. Try clear your cache. – niksmac Apr 21 '12 at 4:09
1

I install 7.x-2.2 version and follow structures, admin/config/people/rpx exists and work correctly.

this may cause because of bad/in-complete installation, install DEVEL module and try: clear cache / re-install / re-build menu

  • i completely removed the module and reinstalled no luck – mcgrailm Apr 21 '12 at 4:34
  • do you try re-build menu / clear cache? you should re-install using devel module. do you use devel? – Mohammad Ali Akbari Apr 21 '12 at 5:17
  • How does one re-install a module "using devel"? – Letharion Apr 21 '12 at 8:24
  • go to devel/reinstall: localhost/devel/reinstall – Mohammad Ali Akbari Apr 21 '12 at 10:02
  • i do not use devel but i could try it – mcgrailm Apr 21 '12 at 12:42
3

The page you are referring to, admin/config/people/rpx, is defined in the module named Janrain Engage UI, machine name rpx_ui. You need to have it enabled for the path to be registered.

  • i added screen shots , I believe those pieces of the module are enabled – mcgrailm Apr 21 '12 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.