2

I am using the CorporateClean theme for Drupal 7.15, and I have an issue using CKEditor with this theme.

When an authenticated user writes some content, the background of the CKEditor text editor (the area where the user can enter and format text) turns black. I do not have this problem when login as the admin. I also do not have this problem if I remove CKEditor.

How can I change this background?

0

Do you have Firebug installed (extension for Firefox) ? With Firebug you can inspect element and see what css definition makes it black. Then, in your theme css file you can override that settings by writting your own definition to make it white. like

.ckebackground {
background-color:#ffffff;
}

where ckebackground is "problematic" class that makes it black.

1
  • 1
    Thank you so much for your anwser. I finally found the solution with firebug (I did not have this one, thank you) and other webdeveloppement tools. The code I added in style.css: .cke_show_borders {background:#fff;}. Later today I found a relatided topic: drupal.org/node/760458 Sorry not to have seen it before. thanks again
    – flore
    Sep 28 '12 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.