0

I have a hard time setting up URL alias patterns when it comes to taxonomy terms. Especially, I'm stunned that in the Replacement under Content Paths, a term reference field shows just one flat item [node:field_term_name], rather than an expandable set of taxonomy-related tokens. This is the way it used to be (as in the screenshot here: Pathauto url of term for node?) Have things changed or is it a bug?

1

Enabling the Entity_Token sub module does help with this issue, however, you need to add a "Term Reference" type field to any of your content types in order to see your taxonomy vocabulary be listed as one of the replacement tokens. In my case, I had enabled the entity_tokens module but I was still not able to see my vocabulary as one of the replacement tokens. Then I added a new field to my "basic page" content type. The field type I added was "term reference" and I selected my custom vocabulary as its default vocabulary. This resolved my issue.

0

After some investigation I found out what was wrong. The key was to enable Entity Token (a submodule of the Entity API package). Following that all the taxonomy reference field's tokens expanded into a subtree and my Pathauto i18n patterns started to work as desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.