There is a url that links to a view that is a page. When clicking the link to that view, a trailing slash gets added and the the page returns 'page not found' nothing about the site gets loaded, just this string as if it said die('page not found') first thing on load. It wouldn't matter if I would manually type the correct url, the trailing slash would be added as well and return the same page not found string.

The only module I could find was global redirect. This module has checkbox in its settings that says 'Deslash'. I tried unchecking - save and checking - save again, but no help.

  • It sounds like the url for the page view is misconfigured in some way. What's in that field on Views UI? Commented Apr 9, 2013 at 10:32
  • The URL is configured at admin/structure/views/view/foto_s/edit and then under page settings where it simply says path/: mypath. Obviously no trailing slash there :)
    – Immers
    Commented Apr 9, 2013 at 13:26
  • And how is your "link" to the view generated?
    – Volker
    Commented Apr 9, 2013 at 13:33
  • This is a basic menu link that sits on the second level in the main menu. I checked that to look if the path in the menu would be something wrong with but the menu making the link can't be the problem. That's why I mentioned that manually typing the correct URL also gives the same problem
    – Immers
    Commented Apr 9, 2013 at 13:37
  • Is there by any chance an actual directory of the same name in your filesystem? Commented Apr 9, 2013 at 13:39

1 Answer 1


There was a folder in drupal installation folder with the exact same name as the path, which added the slash at the end

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.