4

When I paste a URL into a TinyMCE editor using WYWIWYG it converts the text into a link.

So http://vimeo.com/18150336 would be come <a href="http://vimeo.com/18150336">http://vimeo.com/18150336</a>. I would like to keep the plain text. Is their a way to configure TinyMCE to keep the link as plain text.

I do not want to strip out tags as adding a hyperlinks should be an option on the toolbar. It should just not happen by default.

1
  • Also in drupal 7 i try this module TinyMCE and there is this problem, i try to modify the settings of WYSIWYG , and i set "Unlink" then when i write the links in the editor I unlinked the links but don't right. Jul 15 '11 at 13:51
1

This is the solution-- On drupal administration:

Administration » Configuration » Content authoring » Text formats

you must remove "Converts URL into links" and then all it's Right!!

3
  • That is Drupal 7. Also I don't think that will solve the issue. I can strip a tags out on the input filter on submit. That is fine. But I dont want to. I want to strip them out when you paste them in. Only in the WYSIWYG if you click th link button should something become a hyperlink. As I am allowing the link button I can not strip the tags out.
    – Keith
    Jul 15 '11 at 14:26
  • If you want to write with the editor the text:vimeo.com/18150336 you must disable the option "Converts URL into links" and you will make it. Jul 15 '11 at 14:39
  • The WYSIWYG still inserts is as a link. When I save it will be stripped out but that is not what I want. I don't want it to go in as a link.
    – Keith
    Jul 15 '11 at 15:46
0
  • In Drupal 6, go to admin/settings/filters/list
  • Click "configure" for the type of input filter being used
  • Uncheck "URL filter", then Save Configuration

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.