1

I have installed Kickstart Commerce 2. With the demo store, the social media buttons (facebook like, g+, and tweet buttons) are shown at the bottom right of the product page directly below the add to cart button, as shown in this kickstart demo store link, http://demo.commerceguys.com/ck/drinks/drupal-commerce-wake-you).

When I create a new product of a content type that was pre-created by the demo store, these social media icons show up the same way. But now that I have created my own content type for other products I choose to add to my store, this does not display. I thought it was a block, but no blocks seen to have this information.

How do I display social media buttons on new content pages on my Drupal Commerce site?

Thank you to anyone they can offer some direction in this please.

2

Kickstart 2.0 Distro uses the service links function. That's what you're seeing below the "add to cart" button. Pretty easy fix. Make sure the service links module is enabled and hit configure, or visit: .../admin/config/services/service-links.

At the top, you can just check the boxes on whichever content type you want these links displayed, as well as a bunch of other fun features below.

Enjoy!

  • Wow! It took me a whole 5 seconds to get done with the advise. Just what I was looking for, a "hack-free" solution! Thank you, sunrotor! :-) Tom – Tom Isabelle Jun 17 '13 at 22:06
0

There may be different solutions, One can be : Editing the "node content type" or "node-display content type" template and add the necessary code on bottom or on top of the node

node-nodetype.tpl.php

Additional information about how to edit the node content type: https://drupal.org/node/17565

  • Thank you for the advice, Narek! I was hoping to discover a way that I could do this through Drupal's UI versus editing the code. It seems like I should be able to as these social media buttons are appearing on the demo content in my store. Why wouldn't they appear on new content I create? I must be missing some setting. Still searching for a cleaner solution, if there is one. – Tom Isabelle Jun 16 '13 at 9:25
0

If you are not using the demo site store, you will also need to enable the General Services module and then configure which services you want to show at admin/config/services/service-links/services. I have also noticed that the default layout on the product nodes is not ideal. You will have to theme the product page to get the layout you desire.

Additionally, only the admin user is given access to the social media links by default. You will need to give your users permissions using the Service Links -> Access to Service Links.

protected by Clive Feb 6 '14 at 13:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.