0

I have a 3 language website and translated bunch of field labels, the thing is that it works just for some of them not all of them. I created the forms with Entity form module and even when I check the translation for other languages it's there, it just doesn't show the proper translation and keep showing the default language instead.

Any ideas what may have caused it?

  • 1
    Make sure you are using the latest i18n -dev because i18n 1.8 had numerous bugs in i18n_field. – Bojan Zivanovic Jun 17 '13 at 7:10
  • it worked, but still have problem with translating field's options such as radio buttons and checkboxes, the translation is there, still not showing it. plus leave an answer so I can check it as the correct one. – Sohail Jun 17 '13 at 7:30
2

The module used for translating fields (title, help text, description, allowed values) is i18n_field.

Internationalization 1.8 shipped with a broken i18n_field module, so in many cases nothing would get translated.

The first issue that fixed most of the failures was [7.x-1.8 regression] Field translation fails in numerous situations It has now been committed and is a part of the latest -dev release.

Contrib field types such as commerce_price might need the following patch: Extend support for contrib field types

With those patches applied I had no problem with translating any part of a field. For translating allowed values (radio or select fields), my process was this: 1) Go to manage fields, click edit next to my list(text) field. 2) Click the Translate tab on the next page. 3) In the table, find my language and click "translate". 4) I can translate the values under the "Field settings" vertical tab.

Also keep in mind that when showing one of those values on a rendered entity, you need to use the "Default translated" formatter (set under "Manage Display").

| improve this answer | |
  • Thanks Bojan, but I still can't translate label options with the exact same process you mentioned. – Sohail Jun 17 '13 at 19:14
  • I suggest opening an issue in the Internationalization issue queue, and provide exact steps and screenshots detailing where it fails. Post the link here, and I will respond there. – Bojan Zivanovic Jun 17 '13 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.