I've to cope with something very odd: I can't add any type of content anymore. For example: when I go to Content > Add content > Article, I navigate correctly to the 'add acticle' page, but I simply get a white screen. I didn't have this before and I can't remember installing new modules. I already tried to flush all caches, but that didn't solve anything. Even when I add

ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

to my index.php or settings.php file, no erros are displayed. Please help!

Edit 1: going to the Configuration screen doesn't result in a WSOD. There's only a white screen when I try to add content.

Edit 2: I discovered that I also get a WSOD when I try to edit already existing content. Please help me! I really can't do anything anymore!

  • Is there any information in admin/reports/dblog? Sep 9, 2013 at 20:49
  • possible duplicate of How to see the error messages when I get the white screen of death?
    – Mołot
    Sep 9, 2013 at 20:52
  • Do you have to option to go to the URL of the /configuration? or does it show a WSOD on every page no mather where what you type in the adressbar.
    – Vic
    Sep 10, 2013 at 3:59
  • On which environment runs your Drupal website (Windows, Apache, MySql, PHP)? You can check the log files to see what causes the WSOD (if it is a WAMP stack, i.e.: c:/wamp/logs/apache_error.log). I remember that a particular version of PHP (4.3.10) was causing a WSOD ... Sep 10, 2013 at 14:41
  • Ok, create manually the log file in the directory "C:/wamp/www/memopoezie/", named apache_error.log. And retry to add content. If it is PHP error, it will be logged in that file. Sep 10, 2013 at 18:05

2 Answers 2


There was something wrong with my database. I had to delete it and reinstall my backup.


Open your "settings.php" file and add the following at the top:

ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

Update your question to include the errors that show up when you get the white screen.

  • Don't you mean index.php? This a good guide for debugging "White Screen of Death" or WSOD: drupal.org/node/158043 Sep 9, 2013 at 19:53
  • Following your link @KariKääriäinen, I added the code to my index.php file, but after I flushed caches and tried to add a certain content type, no error messages were displayed. I just got exactly the same white screen as before...
    – Jeroen
    Sep 9, 2013 at 20:24
  • Your best bet is to keep going through that list. It's loooong, I know ;) Sep 9, 2013 at 21:00
  • @KariKääriäinen I'm sure index.php works as well, but I'm not sure there's a reason to NOT put it in settings.php from what I can see, both are valid, and recommendations are split regarding where to include it. I would argue that it makes more sense to include in settings.php, since index.php contains no user configurable parameters.
    – jdu
    Sep 11, 2013 at 15:21
  • Thanks. I didn't realize it could work in settings.php equally well. After a short research it looks like the best location can depend on the problem. I would try index.php at least to start with. Sep 11, 2013 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.