0

I am very sorry to bring a rather nebulous question here but need any and all help I can get: for the first time, I've had a "White Screen of Death" issue when trying to update a module. I believe it was the "Metadata" module but I don't even remember for sure. I had a previous backup of the database and site files/folders from a day ago, so I didn't make one this time. Followed the Drupal tool for downloading, installing, and...presto....White Screen of Death.

Trying not to panic, I reverted to the older backup. Which I hoped would solve the issue.

Yet it did not.

So my question is whether perhaps (fingers crossed!) there's additional steps I need to take once a backup is in place to get things working again. I tried truncating every "cache_..." line via PhpMyAdmin, but it didn't help. I tried the "update.php" in the URL hoping it was (maybe) just an index.php issue. Again...no dice.

I've seen a long page about WSOD possible issues but don't want to just muddle around doing that if I don't know what I'm doing, which I don't.

Are there any suggestions for quick, simple things I've either forgotten or could try to get this working again? And if I can't, can I manually copy files and folders over somehow and try again?

Thank you all in advance for any help. I really appreciate it. Stay healthy out there!

  • 1
    When you restore the DB and the sites/files folder, this does not restore your old code base. You also need to restore to the old code base / module versions to turn your backup into a running site. – Hudri Apr 1 at 16:08
  • Hi Hudri. I replaced (via my ISP) the entire root directory and all subfolders, and the database. I didn't just swap out the sites/files. (Though maybe I should double check that they recursively backed up the folder...if they only did the top root directory that would definitely explain things!) Thank you! :-) – user1149499 Apr 2 at 1:22
0

So the solution here was that the backup (done by my ISP) did not fully restore. I think they forgot to recursively restore and just did the main Drupal root. Once I asked them if they were sure they restored recursively and there was a long pause (a few hours, at which point the site started working again) they came back and said they'd missed a few files.

So luckily that solved it. I did not need to configure anything or run any update.php or such. Just restored the entire Drupal directory and all subdirs and such, and a database restore to match. That fixed it. Whew!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.