0

My "Authenticated User" can not see the tab "Publishing options" on the node/add/[content type] page. What I need in my workflow is the user to select the moderation state (Draft/Moderation) the node should be in, but he can't see the tab.

I have 3 moderation states: Draft, In Moderation, Published. Screenshot as admin

The user has the following permissions:

Node:
    View published content
    View own unpublished content
    View content revisions
    create [content type] content
    edit own [content type] content
    edit any [content type] content
Workbench Moderation:
    View the moderation messages on a node
    Use "My Drafts" workbench tab
    View all unpublished content
    View moderation history

I configured the permissions looking at https://www.drupal.org/node/1175592 and https://www.youtube.com/watch?v=8nqWLrxH_4M + https://www.youtube.com/watch?v=qHYWOohhKZE

I don't know if there are other permissions that I forgot. I have already rebuilt the permissions on /admin/reports/status/rebuild, no difference.

Funny thing is that, if I assign all permissions

Moderate all content from Draft to in Moderation
Moderate all content from in Moderation to Draft
Moderate all content from in Moderation to Published

to the anonymous user, he still can't see this tab.

Any help welcome.

  • Did you try doing this on a clean install? What is the setup of the site on which you're trying to do this (e.g. any other moderation/administration modules installed, content/field access modules, etc.)? – Aram Boyajyan Jul 31 '14 at 10:38
  • What do you mean by normal user? Is it authenticated user? Can you please post the screenshot in english language if possible? – MutantMahesh Jul 31 '14 at 13:25
  • Thanks. I updated the question to make it a bit more understandable. Switched to English screenshot. The open tab Publishing options is the one that I can not see as authenticated user – nerdoc Jul 31 '14 at 14:07
  • @Topsitemakers many modules installed & activated, yes. Drupal 7.30/PHP5.4/MySQL; No other moderation modules are installed. Many, many modules, but no other access modules at all. only panel/display suite. But that's not the problem IMHO. we had had workflow/revisioning installed, but wiped them because of their huge complexity. Workbench is simpler, fullfills our needs, the only thing that does NOT work is this issue here. – nerdoc Jul 31 '14 at 15:19
  • Did you try to replicate the issue on a clean install? I can't test this right now, doing this from start might give you a clue where's the issue. – Aram Boyajyan Jul 31 '14 at 15:52
0

Ah. Again, Fooled myself - it was a simple shoot into my own foot. I had written custom PHP code in my costom theme in the function THEME_form_alter() to suppress the whole revisoning tab:

$form['revision_information']['#access'] = FALSE; 

When I then installed and configured the workbench module I didn't realize that it needs exactly THIS tab.

Works as expected now. Sorry for using your time... But maybe someone else learns from my errors... Thanks for your thoughts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.