0

I am using Workbench, Workbench Moderation and Workbench access.

I have a content manager role, who should be able to only create unpublished content, edit content that is flagged as Needs review and change the moderation state from Needs review to Draft. But as i'm testing the role, the manager can go into the draft and change the moderation state to published, or even needs review, and I do not have the permissions set for the user to change the moderation state.

At least I think. I've followed a couple tutorials and my site is configured the same, but when they go to change the moderation state their drop down select list only has the options they specified, while mine has all states available regardless of permissions.

I've tested back and forth between the roles and there is differences in the permissions and what each user role can do, but I can't set the role to allow users to moderate specific state transitions.

I literally can turn off all workbench moderate state permissions and they still have access to change the moderation state to anything they want.

WB settings

As you can see in the bottom right hand corner of the image, the permissions for Moderate all content from ___ to ____ is turned off for my content manager role, and I still have permissions to moderate all content from either state. If i sign is as the reviewer role, I can also turn off all permissions and still be able to moderate the content and change the states without permissions.

No I do not have another role enabled for this user, I have cleared every cache and used different machines, same issue.

My questions are:

if I have a setting on that allow the user to moderate the states of content, what is it?

If I do not have the correct permissions enabled, what should I do to correct it?

If the issue does not lie within the workbench permissions then what should I be looking for?

Thank you regardless.

0

in order to display the moderation states i wanted for a specific role I had to make sure Administer Workbench Moderation and Bypass Moderation restrictions were turned off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.