I followed this video tutorial in youtube for installing TinyMCE Editor in drupal. Below are the steps I did.

1. Downloaded and installed the updated WYSIWYG 7.x-2.2, IMCE 7.x-1.9 and IMCE Wysiwyg API bridge 7.x-1.0 succesfully.

2. Downloaded TinyMCE and placed it on `htdocs\drupal\sites\all\libraries` succesfully.

3. Installed TinyMCE unsuccesfully.

I refresh drupal's page and still gets the 'Not installed.' message.

enter image description here

I suspect the path may be wrong/different from the image above. The actual path in my computer is sites\all\libraries\tinymce\js\tinymce\tinymce.min.js

I downloaded TinyMCE here. Where did I go wrong?

  • Hi @Aliyah, which version of the TinyMCE you are using like 4.x or 3.x? Nov 6, 2015 at 8:25
  • @PankajSachdeva TinyMCE 4.2.7 :)
    – user46175
    Nov 6, 2015 at 8:40
  • 1
    please use the version 3.5.x to work properly. I hope it will work. Nov 6, 2015 at 8:45
  • Have you tried just changing the folder names to match the correct path?
    – Collins
    Nov 6, 2015 at 8:46

2 Answers 2


There might be TinyMCE version issue with 4.7.x. Once I have facing the same problem. Then I uses the version 3.5.x of TinyMCE and its worked fine for me.

I hope it will work.


I had to do quite a bit of work to get WYSIWYG to work properly. While I preferred TinyMCE, I ended up using CKeditor 4.4.4 after it was all said and done, since I am using "Footnotes" Add-on. The setting for this editor were much easier to configure and get working.

Good documentation on this is easy to find and troubleshoot: http://ckeditor.com/

I ended up adding the editor the Libraries folder and changed settings in the modules folder to point to the file directory that was needed. It's been over a year since I did this and I changed things so many times that I can't remember what was right or wrong.

The end result is, it's nice having a WYSIWYG that works, that I haven't had to mess with for over a year.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.