1

I am new to drupal. I am using drupal 8.2.5, bartik theme and i would like to add font size&family and colour buttons to the ckeditor.

i installed the "CKEditor Font Size and Family" module, enabled it and then at "admin-configuration-content authoring-text formats and editors" i configured "Basic HTML" and "Full HTML" and drag the new available buttons of fonts and size to the toolbar. I saved it and then when i tried to add new content (article or basic page), the editor was completely gone, there was only the field of "summary" available to write something! When i disabled the module, the text editor was back to normal.

Later, I noticed at the module page that the installation process was the following:

  1. Download the plugin from http://ckeditor.com/addon/font.
  2. Place the plugin in the root libraries folder (/libraries).
  3. Enable CKEditor Font in the Drupal admin.
  4. Configure your WYSIWYG toolbar to include the buttons.

So I realised i hadn't followed step 2. I don't know where the libraries folder is, although i searched and have no experience how to create it correctly and how to place this plugin there. I read various posts on the internet but couldn't find a solution and then i ended up here. Thank you.

1

You have to create the folder yourself as the docs say.

You can do this with command line with mkdir libraries in the webroot (where the /core folder is), or with a window and New Directory (New Folder) in either Windows / OSX.

Your application structure will then look like...

/core
/libraries
/modules
/themes

and so on.

All thats left is to download the JS plugin from ckeditor.com (v 4.5.x), unzip it, and place it in the libraries directory.

  • Hello, i created a libraries directory via cpanel in the webroot, where the /core folder is, i uploaded the plugin in the libraries, then activated the module but when i went to configure the toolbar, there was no available button for font or size to drag in the active area.Did i miss anything?Thank you once again. – kyriakib Jan 12 '17 at 11:02
  • You need to add the plugin.js and the icon and lang folder – Kevin Jul 10 '18 at 8:48
0

Check the console in your browser for any errors. In my case I hadn't added the panelbutton addon at the /libraries folder

0
  1. So you have created the Drupal/libraries folder. Ensure that you have downloaded and placed the library inside the library folder and the corresponding module in the Drupal/modules folder. (i had once copied module to library and viceversa). Try clearing the cache (Configuration->Performance->Cache) and run Configuration->Cron once.
  2. You have mentioned that the editor is gone. This happens when there is a bug in the module. It happened with me for the 'color button' module. Search Configuration->reports to find the exact error. Once you get the error, you can search in this forum and I am sure a patch will be available for it.
0

a.Download the plugin from http://ckeditor.com/addon/font. b. enable that plugin. c. Enable CKEditor Font in the Drupal admin. d. Configure your WYSIWYG toolbar to include the buttons.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.