0

In Drupal 8 setting url with path prefix for language detection, works fine. But when I include the language switcher block included with Drupal, the links instead of using the language prefix, show links using the variable language in the url.

How can I make the language switcher make use of the language prefix instead?

1 Answer 1

3

The plugins you enable in the language detection configuration also contain the methods to build outbound paths and the language switcher links. The plugin for Url adds prefixes, not query strings. Others do, for example Session for anonymous users, so you probably have enabled a second detection method.

1
  • Thanks @4k4 I have just discovered the problem was caused because Session was enabled also as detection method.
    – jmzea
    May 10, 2018 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.