0

I'm trying to migrate over a Drupal 8 site developed on my local PC to the web host. Everything is fine with the files transferred over (/site/files, /modules, /themes, etc.), the database has been transferred successfully, but it's not being read by Drupal (the new site is blank but with the CSS working fine). My web host insists that everything is fine with the settings.php and other files and suggested that I look here for solutions.

The only lead I have is that I notice that the local site I created on Bitnami/Xampp has five different databases: "bitnami_drupal8", "information_schema", "mysql", "performance_schema", and "sys".

I've been trying to export and import back in the "bitnami_drupal8" database because that seemed to be the main database. There is only one database on my web server (I'm only allowed two).

Do I need to export/import these five databases and merge them into the one on my web host? If not, are there any other suggestions?

Note too: I've tried the Backup & Migrate module with backups of the entire site, imported that in, and it still didn't show anything. It's like there's some incompatibility between the local and web host databases.

Thanks a lot

  • Do I need to export/import these five databases and merge them into the one on my web host? no, you just need the one Drupal DB, "bitnami_drupal8". – No Sssweat Jun 27 '18 at 21:57
  • If you empty the DB in your webhost and go to your site's url do you see the Drupal install page? – No Sssweat Jun 27 '18 at 22:01
  • Yes, every time I empty the DB on the webhost I get the Drupal install page. I may have made a mistake before where I exported all 5 databases from the localhost. I just now tried it again with only the "bitnami_drupal8" database. It's still not working. The webhost site picks up no content even though I can see that it's imported in the database contents. – B. Dawg Jun 28 '18 at 15:01
  • How big is the database export file? What method are you using to import? Going through the interface can be problematic for large files, CLI might be the right way in that case. Check that all tables have been imported, sometimes you have to start the same import several times to get it done in batches, when going through the interface. What do you mean by "blank page but CSS is working"? If it's blank there should be no elements displayed? – prkos Jun 29 '18 at 11:54
  • @prkos It's a fairly new site with only a few pieces of content so the database files should be fairly small. It's a site under development and there hasn't been that much done. The uncompressed database export file is ~23MB. About the "blank page", I meant that none of my content got imported (basically nothing in the database, only the theme and modules files work). As for methods, I've tried importing in the old database through phpMyAdmin and I've also tried doing it with the Backup & Migrate module. Neither worked. – B. Dawg Jun 29 '18 at 21:15
0

Okay I figured it out. It was the database prefix value in the settings.php file that was the problem.

I set up the site on another web host and got it to work there, then I compared the two settings.php files and noticed that the working one had the database prefix blank. The problem occurred with InMotion Hosting but it worked fine on Bluehost.

Thanks for the help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.