I have installed solr 8.2.0 for drupal 8.7.6.

My Solr server and index are enabled and indexed. But when try to search via views, the results are not showing up. Please help me in solving this.

My New view enter image description here

enter image description here

  • Did you create content using devel module? If yes, then try to create the content again and check. Commented Sep 9, 2019 at 11:05
  • The Exposed form style says Input required. Are you entering anything into your Views exposed form? If you're expecting to see all results before using the Exposed form you should change that setting. You should also always add the No results behavior in Views so you can actually tell whether there are no results or there is something else the matter.
    – prkos
    Commented Sep 9, 2019 at 15:21
  • i have added screenshots of new view that i have created. after adding ** No results behaviour** , it shows like above which means contents are there which are not displaying for some reason. please advise
    – Max28
    Commented Sep 10, 2019 at 6:19

1 Answer 1


You need to export the solr conf from drupal and import it into solr server.

The export button is on your server conf in drupal.

The readme of the search api module can guide you about that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.