1

i want to update the core from 8.7.6 to 8.9.2 and when I try this command "composer require drupal/core:^8.9.2 --update-with-dependencies" i have got an error like below , can anyone help me please to solve this and get the migration work

the error :

 Problem 1
    - webflo/drupal-core-require-dev 8.7.6 requires drupal/core 8.7.6 -> satisfiable by drupal/core[8.7.6] but these conflict with your requirements or minimum-stability.
    - webflo/drupal-core-require-dev 8.7.6 requires drupal/core 8.7.6 -> satisfiable by drupal/core[8.7.6] but these conflict with your requirements or minimum-stability.
    - webflo/drupal-core-require-dev 8.7.6 requires drupal/core 8.7.6 -> satisfiable by drupal/core[8.7.6] but these conflict with your requirements or minimum-stability.
    - Installation request for webflo/drupal-core-require-dev (locked at 8.7.6, required as ^8.7.0) -> satisfiable by webflo/drupal-core-require-dev[8.7.6].

my composer.json

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        {
            "type": "package",
            "package": {
                "name": "harvesthq/chosen",
                "version": "1.8.7",
                "type": "drupal-library",
                "dist": {
                    "url": "https://github.com/harvesthq/chosen/releases/download/v1.8.7/chosen_v1.8.7.zip",
                    "type": "zip"
                },
                "require": {
                    "composer/installers": "^1.2.0"
                }
            }
        }
    ],
    "require": {
        "php": ">=5.6",
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.6.5",
        "drupal-composer/drupal-scaffold": "^2.5",
        "drupal/admin_toolbar": "^1.27",
        "drupal/bootstrap_barrio": "^4.22",
        "drupal/bootstrap_layouts": "^5.1",
        "drupal/bootstrap_sass": "^1.9",
        "drupal/chosen": "^2.8",
        "drupal/config_ignore": "^2.1",
        "drupal/config_split": "^1.4",
        "drupal/console": "^1.0.2",
        "drupal/core": "8.7.6",
        "drupal/devel": "^2.1",
        "drupal/ds": "^3.4",
        "drupal/eu_cookie_compliance": "^1.8",
        "drupal/google_analytics": "^3.0",
        "drupal/google_tag": "^1.2",
        "drupal/honeypot": "^1.29",
        "drupal/memcache": "^2.0",
        "drupal/menu_admin_per_menu": "^1.0",
        "drupal/menu_link_attributes": "^1.0",
        "drupal/module_filter": "^3.1",
        "drupal/pathauto": "^1.4",
        "drupal/redirect": "^1.4",
        "drupal/robotstxt": "^1.2",
        "drupal/simple_sitemap": "^3.3",
        "drupal/sitemap": "^1.5",
        "drupal/smtp": "^1.0@beta",
        "drupal/views_bootstrap": "^4.1",
        "drupal/yaml_editor": "^1.0",
        "drush/drush": "^9.0.0",
        "harvesthq/chosen": "^1.8",
        "vlucas/phpdotenv": "^2.4",
        "webflo/drupal-finder": "^1.0.0",
        "webmozart/path-util": "^2.3",
        "zaporylie/composer-drupal-optimizations": "^1.0"
    },
    "require-dev": {
        "webflo/drupal-core-require-dev": "^8.7.0"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ],
        "files": ["load.environment.php"]
    },
    "scripts": {
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ]
    },
    "extra": {
        "composer-exit-on-patch-failure": true,
        "patchLevel": {
            "drupal/core": "-p2"
        },
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/{$name}": ["type:drupal-library"],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/modules/custom/{$name}": ["type:drupal-custom-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/profiles/custom/{$name}": ["type:drupal-custom-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "web/themes/custom/{$name}": ["type:drupal-custom-theme"],
            "drush/Commands/{$name}": ["type:drupal-drush"]
        },
        "drupal-scaffold": {
            "initial": {
                ".editorconfig": "../.editorconfig",
                ".gitattributes": "../.gitattributes"
            }
        }
    }
}

1
0

A few things I would try:

composer require webflo/drupal-core-require-dev 8.9.2

If that fails try deleting the composer.lock file and then running composer update drupal/core --with-dependencies

If your composer.json requirement for drupal/core isn't allowing the jump to 8.9.2, then update that and run the second command again.

7
  • thank you for your res , but i have tried your logic but still have the same error – alex espandora Aug 7 '20 at 16:06
  • Can you add your composer.json file for review? – ben.hamelin Aug 7 '20 at 16:16
  • yes see above in the detail – alex espandora Aug 7 '20 at 16:39
  • 1
    You need to run drush updb. After core upgrade. Take backup before proceeding – miststudent2011 Aug 7 '20 at 23:00
  • 1
    webflo/drupal-core-require-dev is abandoned. Use drupal/core-dev instead. – leymannx Aug 8 '20 at 23:08
0

I have often read this is not the recommended way, but in my Drupal installations I get fewest problems with a simple

composer update

command. This updates all, and solves such dependencies reliable.

Another solution is to combine core and webflo/drupal-core-require-dev in the same composer command:

composer update drupal/core:^8.9.2 webflo/drupal-core-require-dev:^8.9.2 --with-dependencies

Always backup your database and codebase before, so you can switch back if something went terribly wrong.

It could be helpful to read the release notes of the core and module version steps between your upgrade. Sometimes there are important hints.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.