0

I've searched around and either I don't find any questions that address my issue per se, or the solutions offered don't pertain/affect my problem. So here goes:

A D7 site, current core, etc.

I have fields attached to user entities. I don't have any permissions applied to limit access to the fields. All users (including anon) have access to user pages (user/username).

However, attached fields do not appear through views for anonymous users. They do appear for logged in users, and anonymous users can see the Groups Audience (I use organic groups on the site), but no other affiliated data shows (full name, website, twitter, etc).

If my view is a list of fields, the fields do appear, but without content (the labels print if I turn them on, text I have set to display as no results behavior shows, etc). If my view returns a rendered entity all that prints for anonymous users is the user picture and Groups Audience.

I'm at a loss here. Initially I thought it was a views issues; now I'm not so sure. I've checked my permissions multiple times and I can't see what's blocking it. Anonymous users can access user pages. I don't have any field-level restrictions (and enabled the Field Permissions module just to make sure). I don't know what else it could be.

Any help is super appreciated.

  • Have you checked the Access setting on the view configuration page? I would set it to None. – Елин Й. Mar 2 '13 at 20:34
  • @Елин Й. - If the anonymous user has the same permissions and the Access setting on the view, they will be able to see the view. This is definitely a field access issue. – Triskelion Mar 3 '13 at 0:38
  • I just prototyped a view to try to see what your problem might be, and I was unable to reproduce the issue. If the anonymous user could see the view, they could also see the fields. I did not activate OG. The only thing that I can think of is if you have had Field Permissions active, maybe those permissions have persisted. With the Field Permissions module active, go to the fields edit screen at /admin/config/people/accounts/fields, and see if the fields are set as private. If so try deactivating and uninstalling Field Permissions. – Triskelion Mar 3 '13 at 0:56
  • Thanks for looking into it. It did end up being OG-related. I had thought that setting visible for anonymous would override something like in/out group visibility, but I guess not. I suppose it makes sense. It'd be interesting to build a permission interface that offers previews of what different users can see/do and that also provides information of what is affecting or able to affect each one. That's a whole different ball of wax, though. – mbrakken Mar 4 '13 at 18:52
1

After poking around on this for a while I discovered that it is definitely an organic groups permission issue. For the record, I have the 7.x-1.5 version of OG installed.

In OG global permissions (admin/config/group/permissions) the fields attached to the user (and nothing else) are all listed under Organic Groups Field Access along with fields attached to groups and fields attached to group content types. When I give access to non-members the fields appear for anonymous.

I suppose this functionality is designed so you can limit user access to people who are connected through a group. This isn't entirely senseless, but can be frustrating if you don't anticipate that control over some objects will be trumped by OG permissions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.