0

Drupal 7.21 For some reason I can't edit/add permissions for certain content to ANY roles anymore. I first noticed this with one role and that had certain permissions missing. Added the missing permissions and tried to save, but it always reverted back to before save. I deleted the entire role and it doesn't take any permission. Other roles the same issue, can't add any additional permissions for create content even for r administrator (User1)

2
  • Have you checked your recent log messages, or your server logs, for any error messages thrown during your attempts?
    – Triskelion
    Mar 13, 2013 at 1:07
  • yup and it only shows the delete of the content type and the (re)creation of the content type, same for the role. Mar 13, 2013 at 1:50

3 Answers 3

0

This happened to me once not too long ago. It seems that, depending on the type of server you are using, there will be a limit when you save permissions or when you use a lot of memory at one given time. The more roles and the more modules the more check boxes in the permissions page and the larger the calculation needed to be accomplished by the server. I went through the modules and got rid of a few modules and also a role that was not necessary and that solved the problem. I have also read that under settings.php you just uncomment where it says:

ini_set('pcre.backtrack_limit', 200000);
ini_set('pcre.recursion_limit', 200000);
9
  • well... I had civicrm installed, which created a lot check boxes... I also un-commented the 2 lines in settings.php.... still no luck Mar 13, 2013 at 3:08
  • I know the ini_set limit can be set higher. I would contact your hosting company and see what they allow and take it from there.
    – Big Robots
    Mar 13, 2013 at 4:03
  • Now here is the strangest thing. I just edited this ROLE's permissions for NODES and I can add any permission except for this one and only as long as I do it Node by Node. This includes Content Types I created, or from Modules so Mar 13, 2013 at 23:50
  • Man I hate this submit on enter.... Now here is the strangest thing. I just edited this ROLE's, the one I have problems with, permissions for NODES I checked: Create New Content; Edit own Content: Delete Own Content: I can add assign the above to every node except for one and only as long as I do it Node by Node. This includes Content Types I created, or from Modules. Ok more time on my hand , I created a New Content Type and I can assign permissions for that too, so back to the one I have problems with and changed the machine name and now it works too. Mar 14, 2013 at 0:11
  • Are you saying that you got it to work? Or do you still have problems with only ONE Content Type? If so, could you just delete it, and then re-create it? Could you save permissions before? If so, do you have a copy of the site you could use?
    – Big Robots
    Mar 14, 2013 at 1:14
2

I experienced this under Drupal 6.x - it is possibly a similar experience on Drupal 7.x.

The Apache error log (/var/log/httpd/error_log or similar) may show something similar to the following:

... [error] [client ... ] PHP Warning:  Unknown: Input variables exceeded 1000. 
    To increase the limit change max_input_vars in php.ini. in Unknown 
    on line 0, referer: https://.../admin/user/permissions

To resolve add the following to php.ini

max_input_vars = 2000

Reload Apache per your operating system and increase setting if pain persists.

0

I also ran into the same problem once, I solved it by adjusting the suhosin-configuration in server.

Check suhosin enabled in your server and if enabled Change your suhosin.ini or php.ini to allow more (i.e. 1000) vars:

[suhosin]
suhosin.post.max_vars=1000
suhosin.request.max_vars=1000

or if you can't set it in your .htacces

php_value suhosin.post.max_vars 1000
php_value suhosin.request.max_vars 1000

Some other possible solutions can found in this link

3
  • Ok, I tried all the suggestions here, except going to my provider. Mar 13, 2013 at 14:49
  • Ok I tried all the suggestions except going to my provider as suggested in some other thread. also the .htaccess changes... not quite sure where to stick those ... Mar 13, 2013 at 14:51
  • Ok I tried all the suggestions except going to my provider as suggested in some other thread. also the .htaccess changes... not quite sure where to stick those ... I deleted more Roles, delete some Content Types and re-created it again... still nothing... Sorry for the double posting... maybe someone can delete the incomplete replies. Mar 13, 2013 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.