0

I have a View with a Page display that only allows the returned data to be linked if the user is authenticated/logged in. I'm not using any extra modules that I can see (inherited site) that would enable access like this.

I simply want to remove that restriction. There is another view that looks the same except it's for Public and shows all the same data but not linked. (the data are pdf files).

On the authenticated display, next to Access in the Basic Settings it has authenticated user. If I click that user role (not the gear for options), then I'm shown a list of user roles to use for access restrictions. I click "None" and save, but the links are not there as an anon visitor. Same if I try by changing the user to Anonymous User. Note: In the permissions, anon has the right to see webfm attachments.

I noticed the URL is documents-public or documents-auth; so I made it just documents. No luck.

I visited the actual custom-page-type which puts the View in a content pane. I re-ordered the variants, removed all Selection Rules and that didn't do anything either.

I flushed all caches.

Somewhere, the view is still only showing a view based on whether a user is authenticated or not even though I've removed the access (it says "unrestricted" next to access) on both displays and removed all selection rules on the actual page.

I'm stuck on where else to look.

  • 1
    I think what you need to be doing instead is looking at the FIELD formatting, not the View's access permissions. Aall you are doing so far is changing who can actually visit the View's page by changing the Access restrictions in the Basic Settings. So, instead click on the field itself in the Fields section (eg, Content: My PDF or whatever it is called on your site :) and look through all the information in there. Most probable guess is that your anonymous users aren't allowed to see the actual node that the pdf is a field inside of and that's why Views isn't providing the link. – Jimajamma May 8 '13 at 22:43
  • 1
    What @Jimajamma said. ;) Also, you said I'm NOT using any extra modules that I can see (inherited site) that would enable access like this. but then you said that the options for access control are Domain, None, Permission, and Role. By default there's no Domain option, so I assume you maybe have the Domain module installed also...? If so, might also check if that's setting any limitations. And I know you said you cleared the cache, but make sure to clear (and possibly disable) the views cache: admin/build/views/tools – jerdiggity May 8 '13 at 23:04
  • Thanks to both. I see that I do have a WebFM module (web file manager) installed but all the permissions are set to allow access to all. The actual field is the "views-field-file-name" that links to the doc when authenticated. That field, I can't find in any actual content-type. That's why I thought it was a combo of Views and Pages restricting. Yes on the Domain module but no nodes are restricted per domain. Cleared the Views cache. – kelly johnson May 8 '13 at 23:32
  • ..and to clarify.. I removed the page variant of "public" so that only the 'auth' variant passes selection and gets served. However, I then get a 'Page not found' which is weird as I would think the page would show but not the content. – kelly johnson May 8 '13 at 23:54
0

For whatever whack reason, I had to click on the file-name in the views, which was already set to "output with links", change it to without links then back and it works.

Thanks you, JimaJamma and jerdiggity; your answers made me focus on the field in the view.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.