0

I want to style the content within a particular node but the CKeditor seems to interfere with that by introducing unnecessary tags.

In Drupal 6 you could disable it by adding the generated id on the node form to the profile settings of ckeditor.

I could find no similar settings in the Drupal 7 version.

Am I missing something here? Is there no similar configuration for Drupal 7?

or should I go with a hook_form_alter?

Any help is appreciated.

1

You can configure text formats to have different editors with WYSIWYG API, all you need to do is create a new format (like Full HTML) and set it for no editor, then on any node you don't wish to have an editor, simply set the text format to your new custom one.

0

When editing the node, simply choose Full HTML as your text format, configure the html tags as you wish, and save the node.

If you save the node with a different text format selected, CKEditor is not active.

0

I disabled ckeditor in the new private message form using hook form alter.

function mymodule_form_alter (&$form, &$form_state, $form_id) {
  if ($form_id == 'privatemsg_new') {
    $form['body']['#type'] = 'textarea';
  }
}

this works for me. this didn't disable other fields. just the ones i wanted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.