0

When I add an youtube video to a "blog post" content type I automatically get youtube's title/url placed above the video (see screenshot below).

  • I have Drupal 7.7 + Media 7.x-2.x-dev + Media Youtube 7x-1.x-dev installed.
  • I have added to the "blog post" content type a new "video" field with type "multimedia asset" and widget "media file selector".

I would really appreciate any advice on how to remove or change this title.

Screenshot

  • I have the same setup. It does look like the field label. I have my label set to hidden, but it still shows, I'm thinking it's a bug. I just hid mine with css until I could either try to fix the bug or update the module. – Chance G Aug 8 '11 at 17:49
  • Yes. I also believe it is a bug. I have been searching online and other people seem to have the same problem. One possible solution is to insert the video into the WYSIWYG editor (I have tried with CK Editor and it works fine). Nonetheless, I would really appreciate if you could provide more details on how to change this with css. thank you so much! – user512826 Aug 9 '11 at 8:14
  • I have the same problem. The name of youtube video appears in views blocks before thumbnail image. Also, instead of a file name (blabla.jpg) I get youtube video name when I use token to set up og:image in metatags module (otherwise when I use tokens for media image upload fields for the same purpose everything works just fine). So that must be a bug. – user13696 Feb 13 '13 at 23:33
1

Concerns:

Media v2 is not stable right now media 1 is fairly stable and will not give you the title problems you're seeing. You also should not be using the dev version for production sites, not only are they not stable, they will not show update and updating & flushing the database can be problematic.

Uninstall v2:

Also reverting media down is rather drawn out you need to disable sub media types (youtube at the least) then media, then file entity (media v1 comes with it's own entity_file).

Then uninstall media and install v1.

To answer your question:

You might also check http://yoursite.com/admin/config/media/file-types and check the display filters for video. The other place where rocketeerbkw mentioned http://yoursite.com/admin/structure/types/manage/ (your content types machine name example: article/book) might be worth a look as well.

If you are keen on fixing the module I'd suggest installing devel and inspecting the elements, it's probably something in a .tpl somewhere.

| improve this answer | |
1

It looks like that's the field label, which can changed on the manage display page (Structure > Content Types > Manage Display)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.