0

I try not to display the title block for one single content type. I do it in the settings of the title block under Visbility -> Content type there I tick the content type which should not have the title block rendered and I check the options Negate the condition.

Basically this works but for example pages generated from the Views module also get no title block rendered then.

Does anybody know about this (in my opinion) "misbehavior" of the block system and how to work around it?

Maybe it's also a problem of the views module... I guess everything which has a content type gets the title except the excluded content type but Views pages do not have a content type and therefor get excluded too.

1

Do you have Ctools installed? Then you have two visibility plugins for content types. One from Ctools and one from core. Better use that from core, because Ctools is still alpha. If you install the module Block Visibility Groups, then you get the option to negate the condition also for the core plugin.

A core only workaround would be to use the path of the content type and negate this.

  • thx for your hint. But with block visbility groups I've the same problem. Views pages do not have titles with the above rule applied to a block visbility group :-(. – TiMESPLiNTER Oct 24 '16 at 16:05
-1

Perhaps revert the previous VISIBILITY->content type setting and hide the title using CSS

  • That's not really an option because then I would have the title twice in the markup which is not really nice. (I use display suite and add it over the "manage display") to have it at the right position in the markup. – TiMESPLiNTER Oct 24 '16 at 7:17
  • Why did I get -1 poster asked for a workaround and this is a workaround ... – GiorgosK Nov 8 '16 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.