2

Have a multilingual site with English and French, I have all my static text on my page--front.tpl.php wrapped with a t(), cleaned my cache and refreshed the strings, but still i cant find the strings to translate them. I'm I doing something wrong here? example of code on page--front.tpl.php

<div class="class-example">
        <p><a href="node/add/poll" class="create-nav-dim cr-nav-bg mb10"><?php print t('Create New content'); ?></a></p>
        <h2 ><?php print t('OR'); ?></h2>
        <p><a href="#" class="example-class"><?php print t('check our content'); ?></a></p>
      </div>
4

You need to activate the locale module.

Under "Admin >> Configuration" you find a section regional and language.
Add a new language, and set it as default language; after that, you can use the 'translate interface' to translate the strings wrapped in t() for your new language.

| improve this answer | |
  • I did that, still cant find the strings to translate them – saadlulu Feb 15 '12 at 20:35
  • And you are sure you have more then 1 language installed? – dimitril Feb 15 '12 at 20:36
  • yes, have 3 languages installed, the main question is how come I cant find the string in the "translate interface" section? – saadlulu Feb 15 '12 at 20:37
  • Try clearing cache, deinstall and reinstall the locale module. – dimitril Feb 15 '12 at 20:40
  • still nothing, I disabled and re-enabled the modules, and enabled all sub modules – saadlulu Feb 15 '12 at 20:48
3

After you've activated locale.module, you need to switch to another language and view the page in that language — until you do that, the strings to translate aren't added to the database.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.