0

My composer.json is below

{                                                                                                                           "name": "drupal/recommended-project",                                                                                   "description": "Project template for Drupal 8 projects with a relocated document root",                                 "type": "project",                                                                                                      "license": "GPL-2.0-or-later",                                                                                          "homepage": "https://www.drupal.org/project/drupal",                                                                    "support": {                                                                                                                "docs": "https://www.drupal.org/docs/user_guide/en/index.html",                                                         "chat": "https://www.drupal.org/node/314178"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ],
    "require": {
        "composer/installers": "^1.9",
        "drupal/ckeditor_a11ychecker": "^1.0",
        "drupal/ckeditor_bs_grid": "^2.0",
        "drupal/ckeditor_indentblock": "^1.0@beta",
        "drupal/ckeditor_youtube": "^1.3",
        "drupal/codesnippet": "^1.7",
        "drupal/colorbutton": "^1.2",
        "drupal/core-composer-scaffold": "^9",
        "drupal/core-project-message": "^9",
        "drupal/core-recommended": "^9",
        "drupal/danland": "^1.0",
        "drupal/devel": "^4.0",
        "drupal/devel_entity_updates": "^3.0.",
        "drupal/diff": "^1.0",
        "drupal/domain": "^1.0@beta",
        "drupal/facets": "^1.5",
        "drupal/image_resize_filter": "^1.1",
        "drupal/ldap_auth": "^1.16",
        "drupal/search_api": "^1.17",
        "drupal/search_api_db": "^1.17",
        "drupal/search_api_solr": "^4.1",
        "drupal/vartheme_bs4": "^6.13",
        "typo3/phar-stream-wrapper": "^3.1"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "stable",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "extra": {
        "drupal-scaffold": {
            "locations": {
                "web-root": "web/"
            }
        },
        "installer-paths": {
            "web/core": [
                "type:drupal-core"
            ],
            "web/libraries/{$name}": [
                "type:drupal-library"
            ],
            "web/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "web/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "web/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/Commands/contrib/{$name}": [
                "type:drupal-drush"
            ],
            "web/modules/custom/{$name}": [
                "type:drupal-custom-module"
            ],
            "web/themes/custom/{$name}": [
                "type:drupal-custom-theme"
            ]
        },
        "drupal-core-project-message": {
            "include-keys": [
                "homepage",
                "support"
            ],
            "post-create-project-cmd-message": [
                "<bg=blue;fg=white>                                                         </>",
                "<bg=blue;fg=white>  Congratulations, you’ve installed the Drupal codebase  </>",
                "<bg=blue;fg=white>  from the drupal/recommended-project template!          </>",
                "<bg=blue;fg=white>                                                         </>",
                "",
                "<bg=yellow;fg=black>Next steps</>:",
                "  * Install the site: https://www.drupal.org/docs/8/install",
                "  * Read the user guide: https://www.drupal.org/docs/user_guide/en/index.html",
                "  * Get support: https://www.drupal.org/support",
                "  * Get involved with the Drupal community:",
                "      https://www.drupal.org/getting-involved",
                "  * Remove the plugin that prints this message:",
                "      composer remove drupal/core-project-message"
            ]
        }
    }
}

When I run composer update drupal/core-recommended --with-dependencies i get this:

Dependency "typo3/phar-stream-wrapper" is also a root requirement, but is not explicitly allowed. Ignoring.
Dependency "typo3/phar-stream-wrapper" is also a root requirement, but is not explicitly allowed. Ignoring.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - drupal/core 8.7.9 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.8 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.7 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.6 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.5 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.4 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.3 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.2 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.14 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.13 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.12 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.11 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.10 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.1 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.7.0 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.9 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.8 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.7 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.6 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.18 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.17 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.16 requires typo3/phar-stream-wrapper ^2.1.1 -> satisfiable by typo3/phar-stream-wrapper[v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.15 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.14 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.13 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.12 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.11 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.6.10 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.9 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.15 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.14 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.13 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.12 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.11 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core 8.5.10 requires typo3/phar-stream-wrapper ^2.0.1 -> satisfiable by typo3/phar-stream-wrapper[v2.0.1, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.2.0, v2.2.1, v2.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.1 requires drupal/core 9.1.x-dev -> satisfiable by drupal/core[9.1.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.0 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.2 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.3 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.4 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - Conclusion: don't install typo3/phar-stream-wrapper v3.1.6
    - Conclusion: remove drupal/core 9.0.11
    - Conclusion: don't install drupal/core 8.9.13
    - Conclusion: don't install drupal/core 9.0.11
    - Conclusion: don't install drupal/core 8.9.12
    - drupal/core-recommended 9.0.11 requires drupal/core 9.0.11 -> satisfiable by drupal/core[9.0.11].
    - drupal/core-recommended 9.0.11 requires drupal/core 9.0.11 -> satisfiable by drupal/core[9.0.11].
    - drupal/core-recommended 9.0.11 requires drupal/core 9.0.11 -> satisfiable by drupal/core[9.0.11].
    - Conclusion: don't install drupal/core 9.0.11
    - Conclusion: don't install drupal/core 8.9.11
    - drupal/core-recommended 9.0.10 requires drupal/core 9.0.10 -> satisfiable by drupal/core[9.0.10].
    - Conclusion: don't install drupal/core 9.0.10
    - Conclusion: don't install drupal/core 8.9.10
    - drupal/core-recommended 9.0.9 requires drupal/core 9.0.9 -> satisfiable by drupal/core[9.0.9].
    - Conclusion: don't install drupal/core 9.0.9
    - Conclusion: don't install drupal/core 8.9.9
    - drupal/core-recommended 9.0.8 requires drupal/core 9.0.8 -> satisfiable by drupal/core[9.0.8].
    - Conclusion: don't install drupal/core 9.0.8
    - Conclusion: don't install drupal/core 8.9.8
    - drupal/core-recommended 9.0.7 requires drupal/core 9.0.7 -> satisfiable by drupal/core[9.0.7].
    - Conclusion: don't install drupal/core 9.0.7
    - Conclusion: don't install drupal/core 8.9.7
    - drupal/core-recommended 9.0.6 requires drupal/core 9.0.6 -> satisfiable by drupal/core[9.0.6].
    - Conclusion: don't install drupal/core 9.0.6
    - Conclusion: don't install drupal/core 8.9.6
    - drupal/core-recommended 9.0.5 requires drupal/core 9.0.5 -> satisfiable by drupal/core[9.0.5].
    - Conclusion: don't install drupal/core 9.0.5
    - Conclusion: don't install drupal/core 8.9.5
    - drupal/core-recommended 9.0.4 requires drupal/core 9.0.4 -> satisfiable by drupal/core[9.0.4].
    - Conclusion: don't install drupal/core 9.0.4
    - Conclusion: don't install drupal/core 8.9.4
    - drupal/core-recommended 9.0.3 requires drupal/core 9.0.3 -> satisfiable by drupal/core[9.0.3].
    - Conclusion: don't install drupal/core 9.0.3
    - Conclusion: don't install drupal/core 8.9.3
    - drupal/core-recommended 9.0.2 requires drupal/core 9.0.2 -> satisfiable by drupal/core[9.0.2].
    - Conclusion: don't install drupal/core 9.0.2
    - Conclusion: don't install drupal/core 8.9.2
    - Installation request for typo3/phar-stream-wrapper (locked at v3.1.4, required as ^3.1) -> satisfiable by typo3/phar-stream-wrapper[v3.1.4].
    - Removal request for drupal/ckeditor_a11ychecker == 1.9999999.9999999.9999999-dev
    - Installation request for drupal/ckeditor_a11ychecker ^1.0 -> satisfiable by drupal/ckeditor_a11ychecker[1.0.0, 1.x-dev].
    - drupal/core-recommended 9.0.1 requires drupal/core 9.0.1 -> satisfiable by drupal/core[9.0.1].
    - Conclusion: don't install drupal/core 9.0.1
    - drupal/ckeditor_a11ychecker 1.0.0 requires drupal/core ^8 -> satisfiable by drupal/core[8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.1.1, 8.1.10, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.2.0, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.3.0, 8.3.1, 8.3.2, 8.3.3, 8.3.4, 8.3.5, 8.3.6, 8.3.7, 8.3.8, 8.3.9, 8.4.0, 8.4.1, 8.4.2, 8.4.3, 8.4.4, 8.4.5, 8.4.6, 8.4.7, 8.4.8, 8.5.0, 8.5.1, 8.5.10, 8.5.11, 8.5.12, 8.5.13, 8.5.14, 8.5.15, 8.5.2, 8.5.3, 8.5.4, 8.5.5, 8.5.6, 8.5.7, 8.5.8, 8.5.9, 8.6.0, 8.6.1, 8.6.10, 8.6.11, 8.6.12, 8.6.13, 8.6.14, 8.6.15, 8.6.16, 8.6.17, 8.6.18, 8.6.2, 8.6.3, 8.6.4, 8.6.5, 8.6.6, 8.6.7, 8.6.8, 8.6.9, 8.7.0, 8.7.1, 8.7.10, 8.7.11, 8.7.12, 8.7.13, 8.7.14, 8.7.2, 8.7.3, 8.7.4, 8.7.5, 8.7.6, 8.7.7, 8.7.8, 8.7.9, 8.8.0, 8.8.1, 8.8.10, 8.8.11, 8.8.12, 8.8.2, 8.8.3, 8.8.4, 8.8.5, 8.8.6, 8.8.7, 8.8.8, 8.8.9, 8.9.0, 8.9.1, 8.9.10, 8.9.11, 8.9.12, 8.9.13, 8.9.2, 8.9.3, 8.9.4, 8.9.5, 8.9.6, 8.9.7, 8.9.8, 8.9.9].
    - Can only install one of: drupal/core[9.0.0, 8.0.0].
    - Can only install one of: drupal/core[9.0.0, 8.0.1].
    - Can only install one of: drupal/core[9.0.0, 8.0.2].
    - Can only install one of: drupal/core[9.0.0, 8.0.3].
    - Can only install one of: drupal/core[9.0.0, 8.0.4].
    - Can only install one of: drupal/core[9.0.0, 8.0.5].
    - Can only install one of: drupal/core[9.0.0, 8.0.6].
    - Can only install one of: drupal/core[9.0.0, 8.1.0].
    - Can only install one of: drupal/core[9.0.0, 8.1.1].
    - Can only install one of: drupal/core[9.0.0, 8.1.10].
    - Can only install one of: drupal/core[9.0.0, 8.1.2].
    - Can only install one of: drupal/core[9.0.0, 8.1.3].
    - Can only install one of: drupal/core[9.0.0, 8.1.4].
    - Can only install one of: drupal/core[9.0.0, 8.1.5].
    - Can only install one of: drupal/core[9.0.0, 8.1.6].
    - Can only install one of: drupal/core[9.0.0, 8.1.7].
    - Can only install one of: drupal/core[9.0.0, 8.1.8].
    - Can only install one of: drupal/core[9.0.0, 8.1.9].
    - Can only install one of: drupal/core[9.0.0, 8.2.0].
    - Can only install one of: drupal/core[9.0.0, 8.2.1].
    - Can only install one of: drupal/core[9.0.0, 8.2.2].
    - Can only install one of: drupal/core[9.0.0, 8.2.3].
    - Can only install one of: drupal/core[9.0.0, 8.2.4].
    - Can only install one of: drupal/core[9.0.0, 8.2.5].
    - Can only install one of: drupal/core[9.0.0, 8.2.6].
    - Can only install one of: drupal/core[9.0.0, 8.2.7].
    - Can only install one of: drupal/core[9.0.0, 8.2.8].
    - Can only install one of: drupal/core[9.0.0, 8.3.0].
    - Can only install one of: drupal/core[9.0.0, 8.3.1].
    - Can only install one of: drupal/core[9.0.0, 8.3.2].
    - Can only install one of: drupal/core[9.0.0, 8.3.3].
    - Can only install one of: drupal/core[9.0.0, 8.3.4].
    - Can only install one of: drupal/core[9.0.0, 8.3.5].
    - Can only install one of: drupal/core[9.0.0, 8.3.6].
    - Can only install one of: drupal/core[9.0.0, 8.3.7].
    - Can only install one of: drupal/core[9.0.0, 8.3.8].
    - Can only install one of: drupal/core[9.0.0, 8.3.9].
    - Can only install one of: drupal/core[9.0.0, 8.4.0].
    - Can only install one of: drupal/core[9.0.0, 8.4.1].
    - Can only install one of: drupal/core[9.0.0, 8.4.2].
    - Can only install one of: drupal/core[9.0.0, 8.4.3].
    - Can only install one of: drupal/core[9.0.0, 8.4.4].
    - Can only install one of: drupal/core[9.0.0, 8.4.5].
    - Can only install one of: drupal/core[9.0.0, 8.4.6].
    - Can only install one of: drupal/core[9.0.0, 8.4.7].
    - Can only install one of: drupal/core[9.0.0, 8.4.8].
    - Can only install one of: drupal/core[9.0.0, 8.5.0].
    - Can only install one of: drupal/core[9.0.0, 8.5.1].
    - Can only install one of: drupal/core[9.0.0, 8.5.2].
    - Can only install one of: drupal/core[9.0.0, 8.5.3].
    - Can only install one of: drupal/core[9.0.0, 8.5.4].
    - Can only install one of: drupal/core[9.0.0, 8.5.5].
    - Can only install one of: drupal/core[9.0.0, 8.5.6].
    - Can only install one of: drupal/core[9.0.0, 8.5.7].
    - Can only install one of: drupal/core[9.0.0, 8.5.8].
    - Can only install one of: drupal/core[9.0.0, 8.6.0].
    - Can only install one of: drupal/core[9.0.0, 8.6.1].
    - Can only install one of: drupal/core[9.0.0, 8.6.2].
    - Can only install one of: drupal/core[9.0.0, 8.6.3].
    - Can only install one of: drupal/core[9.0.0, 8.6.4].
    - Can only install one of: drupal/core[9.0.0, 8.6.5].
    - Can only install one of: drupal/core[9.0.0, 8.8.0].
    - Can only install one of: drupal/core[9.0.0, 8.8.1].
    - Can only install one of: drupal/core[9.0.0, 8.8.10].
    - Can only install one of: drupal/core[9.0.0, 8.8.11].
    - Can only install one of: drupal/core[9.0.0, 8.8.12].
    - Can only install one of: drupal/core[9.0.0, 8.8.2].
    - Can only install one of: drupal/core[9.0.0, 8.8.3].
    - Can only install one of: drupal/core[9.0.0, 8.8.4].
    - Can only install one of: drupal/core[9.0.0, 8.8.5].
    - Can only install one of: drupal/core[9.0.0, 8.8.6].
    - Can only install one of: drupal/core[9.0.0, 8.8.7].
    - Can only install one of: drupal/core[9.0.0, 8.8.8].
    - Can only install one of: drupal/core[9.0.0, 8.8.9].
    - Can only install one of: drupal/core[9.0.0, 8.9.0].
    - Can only install one of: drupal/core[9.0.0, 8.9.1].
    - drupal/core-recommended 9.0.0 requires drupal/core 9.0.0 -> satisfiable by drupal/core[9.0.0].
    - Installation request for drupal/core-recommended ^9 -> satisfiable by drupal/core-recommended[9.0.0, 9.0.1, 9.0.10, 9.0.11, 9.0.2, 9.0.3, 9.0.4, 9.0.5, 9.0.6, 9.0.7, 9.0.8, 9.0.9, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4].

When I run composer require drupal/core-recommended I get :

Using version ^9.1 for drupal/core-recommended
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for typo3/phar-stream-wrapper (locked at v3.1.4, required as ^3.1) -> satisfiable by typo3/phar-stream-wrapper[v3.1.4].
    - drupal/core-recommended 9.1.1 requires drupal/core 9.1.x-dev -> satisfiable by drupal/core[9.1.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.0 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.2 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.3 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - drupal/core-recommended 9.1.4 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6].
    - Conclusion: don't install typo3/phar-stream-wrapper v3.1.6
    - Installation request for drupal/core-recommended ^9.1 -> satisfiable by drupal/core-recommended[9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4].


Installation failed, reverting ./composer.json to its original content.

Not sure what to do. I thought changing my min stability from 'dev' to 'stable' per the notes on upgrading to Drupal 9.1 would be enough but it still won't upgrade. Any help would be appreciated

EDIT 2:

Tried to remove the problematic module and got this:

Dependency "typo3/phar-stream-wrapper" is also a root requirement, but is not explicitly allowed. Ignoring.             Loading composer repositories with package information                                                                  Updating dependencies (including require-dev)                                                                           Your requirements could not be resolved to an installable set of packages.                                                                                                                                                                        Problem 1                                                                                                                 - The requested package drupal/core-recommended (locked at 9.0.11, required as ^9.1) is satisfiable by drupal/core-recommended[9.0.11] but these conflict with your requirements or minimum-stability.                                        Problem 2                                                                                                                 - The requested package typo3/phar-stream-wrapper (locked at v3.1.4, required as 3.1.5) is satisfiable by typo3/phar-stream-wrapper[v3.1.4] but these conflict with your requirements or minimum-stability.                                   Problem 3
    - drupal/core-recommended 9.1.5 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.4 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.3 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.2 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.1 requires drupal/core 9.1.x-dev -> satisfiable by drupal/core[9.1.x-dev] but these conflict with your requirements or minimum-stability.
    - drupal/core-recommended 9.1.0 requires typo3/phar-stream-wrapper v3.1.6 -> satisfiable by typo3/phar-stream-wrapper[v3.1.6] but these conflict with your requirements or minimum-stability.
    - Installation request for drupal/core-recommended ^9.1 -> satisfiable by drupal/core-recommended[9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4, 9.1.5].
6
  • Looks like this module drupal/ckeditor_a11ychecker isn't ready for Drupal 9 – yvan Mar 3 at 22:20
  • i am running drupal 9.0.11 – Matt S Mar 3 at 23:02
  • drupal/ckeditor_a11ychecker doesn't work with Drupal 9. That is what drupal/ckeditor_a11ychecker 1.0.0 requires drupal/core ^8 in the error message is saying. Version 8.x-1.0 has been released on June, 2016. Only the 8.x-1.x development snapshot has been recently updated (June, 2020) and it's compatible with Drupal 9. – kiamlaluno Mar 4 at 14:54
  • gotcha, i tried to install the update for it and got this: Check the edit – Matt S Mar 4 at 18:00
  • I think you need to change the minimum-stability of your composer to dev in order to install the right version of module. – yvan Mar 5 at 13:45
0

The error is here:

- drupal/ckeditor_a11ychecker 1.0.0 requires drupal/core ^8 -> satisfiable by drupal/core[8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4,...].

The ^8 in this line means that the version number of drupal/core must begin with an 8. You are requesting a version of core that begins with a 9. Therefore the installation fails.

The solution is to run composer remove drupal/ckeditor_a11ychecker before running your update process, to remove this conflict.

4
  • Check the edit for an update – Matt S Mar 4 at 18:24
  • As others have mentioned, this module does not have a D9 ready version. This is why Composer failed in your previous attempt - it tried to find compatible versions, but no version of this module is compatible with Drupal 9. So you'll either have to wait to upgrade, remove this module and upgrade, or find some alternate solution. – Jaypan Mar 4 at 18:32
  • Check the latest update – Matt S Mar 4 at 21:24
  • That's a new problem. The previous one has been solved. – Jaypan Mar 4 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.