1

I'm trying to make a fully bilingual website that will be administered by French and English users.

I've installed the internationalization module and all its dependencies and the localization update module, which claims to have installed French language support. I've successfully got all the front-end content, menus and views translated and language switching working, but no matter what I do, the admin menus remain in English. It doesn't matter whether I change my default language in the user preferences or set the site to French with a url parameter, I can't get the admin menus to change language. Many of the tutorials I've seen online seem to gloss over this as though it happens automatically.

Is it possible to display Dashboard, Content, Structure...etc in French as well as the default English or am I going nuts?

  • Are you using URL prefix as your translation detection method? (or sub-domain based? or other?) Do the URLs of the admin menu items have the correct language prefix? – bgm Oct 27 '14 at 16:34
  • @bgm - my order of priority goes URL -> Session -> User Preference. The URLs do have the correct language prefix. – Ambulare Oct 27 '14 at 16:51
3

If you swap from french to English the admin menu should also switch from french to English (Drupal 7).

In the tag "detection and selection" of Admin/Configuration/Regional and language/Languages" click the "Default" checkbox in order to use the default site language.

The "Localization update" module also helps you keep your interface translations for core and contributed modules up-to-date :

  1. Enable the Locale (core) module
  2. Download and enable the "Localization update" module
  3. Go to the configuration page at admin/config/regional and language/translate interface/update
  4. Wait as the module looks for translation updates
  5. Click Refresh information button at the bottom of the page
  6. Wait as the module gets all translations
  7. Disable the Localization update module when finished to improve site performance.
  • Thank you for your comprehensive reply, but I'm afraid it is not working. When I switch languages, my user content is translated, but the admin menu remains in English at all times. – Ambulare Oct 27 '14 at 17:12
  • I never encountered a similar issue. I found that the problem might be caused by the "Admin Language" Module if it is installed on your site. Disabling it may fix the issue. – FL26 Oct 27 '14 at 17:22
  • Follow up: apologies for my previous comment. On refreshing the information and re-downloading the language packs it all worked. Thank you for your help. – Ambulare Oct 27 '14 at 17:22
1

Did you enable the sub-module menu translation of internationalization (if yes) go to your menu and click on translate. If not go ahead and enable it. It will work

  • thank you for your feedback, but I cannot manually translate the entire admin interface - isn't the localisation update module supposed to import the translations? – Ambulare Oct 27 '14 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.