1

I was trying to install Aegir following the Automatic install guide, but I get an error. I've tried to install Aegir 2, then tried also Aegir 3, but the error is the same. Any clues?

Here's the message:

The following settings will be used: Aegir frontend URL: site.dev.local Master server FQDN: site.dev.local Aegir root: /var/aegir Aegir user: aegir Web group: www-data Web server: apache Web server port: 80 Aegir DB host: localhost Aegir DB user: root Aegir DB password: Aegir DB port: 3306 Aegir version: 7.x-3.x Aegir platform path: /var/aegir/hostmaster-7.x-3.x Admin email: aegir@site.dev.local

Aegir install profile: hostmaster

Do you really want to proceed with the install (y/n): y Enabling hosting-queued daemon

The drush command '@hostmaster pm-enable hosting_queued' could not be found. Run drush cache-clear drush to clear the commandfile cache if you have installed new extensions. [error] A Drupal installation directory could not be found [error]

dpkg: error processing package aegir3-hostmaster (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of aegir3: aegir3 depends on aegir3-hostmaster (>= 3.0.1); however: Package aegir3-hostmaster is not configured yet.

dpkg: error processing package aegir3 (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. Errors were encountered while processing: aegir3-hostmaster aegir3 E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks!

1

The most common problem that could cause this is a broken mail setup.

Please the if you can sent an email from the server's cli to aegir@site.dev.local

0

Ran into this today, here's how I solved it:

Set -x in the script which is failing.

You can do this by editing the .postinst script, eg /var/lib/dpkg/info/aegir3-hostmaster.postinst in my situation. Replace #! /bin/sh with #! /bin/sh -x at the top of the script; when executed, the postinst script will then print out each line as it's executed.

Set DPKG_DEBUG=developer.

export DPKG_DEBUG=developer

This will activate debug output in various script commands.

Re-run the installation.

For me, this was dpkg --configure --pending as I'd already attempted to install the package and it had failed during configuration.

Read the output.

Seems obvious, but the first couple times I didn't read back far enough, and there was a useful error message further up.

In my case (quite possibly not yours, dear reader), the issue was that the permissions of /var/aegir/platforms in my Vagrant environment did not permit the aegir user to create the directory to install its hostmaster install. Thus no @hostmaster alias, no way to enable hosting_queued, and an error message which didn't clearly point to a resolvable situation.

Fix the root problem.

This will vary, as the error in this question is associated with many different causes documented across the internet, including:

  • MySQL validate password plugin not accepting the generated password. (Generate a better password, or reconfigure / disable that plugin.)
  • The aegir hostname not being resolvable, so the site being inaccessible. (Add the aegir hostname in /etc/hosts)
  • Filesystem permissions preventing installation. (Make sure aegir owns the platforms directory.)

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.