0

I just update a site from Drupal 7.14 to Drupal 7.15 and made some other modules updates.

One of the content I have created in the site is Inmuebles

The site have around 200 nodes of the Inmueble type. All of them are shown fine. But if I tried to edit them I get a blank page (nothing at all).

I tried to Edit the content type Inmueble itself and I get a blank page.

I tried to Manage the Fields and I get a blank page.

I have no problems with other content types, just with this one.

I guess this content type has a mis-configuration but I see no way to fix it if I can't access to modify it.

If I delete the content type because I will delete the nodes as well, then I can't do that.

What can I do? I have Drush installed, just in case it helps to fix this.

UPDATE

Found the problem (but not the source of the problem) It was a problem of memory size. I had to set the memory size to 512 to get the content type loaded. But this is not normal anyway. The page takes 1 minute to load... and why does this content type need this much memory to work fine. How can I fix this?

I enabled Display query log , Display memory usage and Display memory usage Now if I edit a node I get this summary report:

Executed 731 queries in 555.96 ms. Queries exceeding 5 ms are highlighted. Page execution time was 3058.65 ms. Memory used at: devel_boot()=2.08 MB, devel_shutdown()=135.13 MB, PHP peak=137.25 MB.

6
  • 2
    Enable error reporting using drupal.org/node/158043 and post the errors you see in blank page here... That will help to find the problem... – Anil Sagar Sep 25 '12 at 11:45
  • 1
    Drupal 14 to 15 ? Guess I overslept again. Time to go back to the past. – GoodSp33d Sep 25 '12 at 11:55
  • Actually 7.14 to 7.15 i guess :-) Edited ! – Anil Sagar Sep 25 '12 at 11:58
  • yeah I meant 7.14. – chefnelone Sep 25 '12 at 12:02
  • found the source of the problem. please see my update at the bottom of the question. – chefnelone Sep 25 '12 at 12:07
0

You can export all the nodes of content type "Inmuebles" with the drush command

drush -u 1 ne-export --type=inmuebles

Then maybe try deleting the content type and creating it again.

Although it doesnt make sense for a content type to just get corrupt, maybe if you check your error reports or apache log you will get a better look.

4
  • Importing is again a pain and if any references to that content will be lost like comments and node references...So deleting a content type or nodes is not an option !! – Anil Sagar Sep 25 '12 at 11:48
  • If you have any custom theme installed, try switching to Drupal "Bartick" theme and check if its working. – saadlulu Sep 25 '12 at 11:51
  • Node export should preserve noderefs and comments if you have the proper sub-modules enabled. You can always take a backup, try this method, and restore the backup if it doesn't work. – mpdonadio Sep 25 '12 at 13:12
  • I have Bartik enabled, I found what is the problem but not the source of the problem. Pls see my updates at the bottom of the question – chefnelone Sep 25 '12 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.